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http://prism.mit.edu/xray 
 

 

 

 

This instrument uses a Vantec2000 2D detector to collect a large amount of data simultaneously.  

This allows for very fast phase identification, as well as the ability: 

 to collect data from samples with large grain size 

 to quickly identify preferred orientation and collect pole figures to quantify the orientation 

distribution 

 to use a small X-ray beam to probe specific areas of a sample (microdiffraction) 

 

The instrument allows features: 

 Incident-beam monochromator to remove Cu K-beta and W L radiation from the X-ray 

spectrum 

 Choice of incident-beam collimators 

 Open Eularian Cradle for tilt (psi) and rotation (phi) of sample 

 Motorized xyz stage for positioning of sample 

 

  

mailto:settens@mit.edu
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When using this instrument, please remember the following warnings:  
 always check the shutter open/closed indicator inside the instrument enclosure 

o the software does not always correctly indicate if the shutter is open or closed 

 do not touch the face of the detector 

 do not bump the video camera and laser- these are precisely aligned to give you good data 

 watch for collisions 

o watch the sample to make sure that it does not hit the collimator when OMEGA < 10deg 

o do not drive OMEGA to an angle higher than 2THETA. If moving both positions, it is 

usually better to drive one and then the other rather than driving both at the same time. 

 Use CTRL+C to stop an action- for example, if you need to prevent a collision when moving 

a goniometer motor or collecting data.  

 If you are not near the keyboard and need to stop an action, hit the STOP button on the 

instrument control column.  

 

The tube operating power is 40 kV and 40 mA. 

The tube standby power is 20 kV and 5 mA. 
Do not turn the generator off- we want to always leave the instrument on.  
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Appendix A. Background on 2D Diffraction      

 

Instructions for Planning a Texture Measurement using Multex Area are written in another SOP. 

 

 

 

I.  USING GADDS TO COLLECT ROUTINE DIFFRACTION DATA (A SINGLE SET OF SCANS) 

 

1. Start GADDS 

There are two versions of the GADDS software: GADDS and GADDS Off-Line.  

 

GADDS communicates with the instrument and is used for data collection and analysis. 

GADDS cannot be used to analyze data while it is also being used to collect data. 

GADDS Off-Line does not communicate with the diffractometer and is used only for 

data analysis. 

Use GADDS Off-Line to analyze data when GADDS is being used to collect data.  

 

 

1) Start the GADDS program.   

a) A dialogue will ask if you want to set the generator power to 40 kV and 40 mA.  

b) Click NO- do not turn up the generator power until after you have loaded your sample. 
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2. CREATE A NEW PROJECT OR OPEN AN EXISTING PROJECT 

Projects are used to specify the folder where data will be saved and to set default values for the 

title during data collection.  

 

A. To create a new project 

Projects are used to set the folder where your data will be saved.  The program generally expects 

that you will save data from different experiments in different subfolders.  

 

1) Select the menu item Project > New  

2) The Options for Project dialogue window will open.  

3) Fill out the Options for Project dialogue 

a) The Sample Name is not very important.  It is used retrieve the project at a 

later time. 

i) The sample name must consist of letters and numbers only 

b) The Title is the default title in the header for all scans.  

i) The Title can be changed when collecting a scan.  

c) The Working Directory is the most important 

information to enter in the Options for Project 

dialogue 

i) This is the folder where your data will be saved 

ii) The beginning of the pathname should always be 

C:\Frames\Data\ 

iii) Then designate your personal folder and any 

subfolders that you want 

d) Click OK 

 

B. To open an existing project 

 Go to Project > Switch 

 Select your project from the database 

 Click OK 

 

OR 

 

 Go to Project > Load 

 Navigate to the folder where data for the project is saved 

 Select the gadds._nc file that is in that folder 

 Click OK 

 

 

3. CHECK THE INSTRUMENT CONFIGURATION 
 

A. First, make sure that the generator power is at 20kV and 5mA 

○ Go to Collect > Goniometer > Generator 

○ Set the power to 20kV and 5mA 

○ Click OK 
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B. Checking Instrument Status and Opening Doors 

1) Before opening the enclosure doors 

 Look at the interior right-hand side of the enclosure.  There is a black 

box with several warning indicator lights.   

 The orange “X-RAY ON” lights should be lit.  These indicate the 

generator is on and the instrument is collecting data.  

 The green “SHUTTER CLOSED” lights should be lit.   

 If the green “SHUTTER CLOSED” lights are not lit or if the red 

“SHUTTER OPEN” lights are lit, then do not open the doors.  

o Look at the instrument computer and determine if a measurement is 

in progress.  If so, wait until it finishes or manually stop it by 

pressing CTRL + C on the keyboard.  

o If no measurement is in progress, then something is wrong.  Do not 

attempt to operate the instrument.  Contact SEF staff to report the 

problem.   

 

2) To open the enclosure doors 

 On either column on the lower sides of the instrument, find the green 

“Open Door” button.  Press this button to unlock the doors.  

 Pull the door handle out towards you.  Gently slide the doors open.  

 To close the doors, gently slide the doors closed.  Push the handles in 

towards the instrument.  

 

C. Check and Change the Incident-Beam Collimator  

There are two different styles of collimator in a variety of sizes that you can use.  

 Monocapillary (fiber-optic) collimators produce a high-intensity but more divergent beam 

○ 0.5mm, 0.3mm and 0.05mm diameter sizes are available 

 Pinhole collimators produce tighter collimation and better resolution,  

○ 0.8mm, 0.5mm, 0.1mm, 0.05mm diameters sizes are available  

 

The 0.5mm pinhole is the most commonly used for good intensity and resolution.  The 0.3mm 

monocap is most often used when you need more intensity. The table below compares the 

intensity and resolution of different collimator and detector distance combinations.     
  Si(111) at 28.44° Si(422) at 88.03° 

Collimator Detector 

Distance 

Area 

(cpsx100) 

Ht:Bkg 

(cpsx100) 

FWHM 

(°) 

Area 

(cpsx100) 

Ht:Bkg 

(cpsx100) 

FWHM 

(°) 

0.05mm monocap 18.61cm 23 73:1 0.277 4 13:0.4 0.28 

0.3mm monocap 18.61cm 1376 3406:58 0.352 303 688:23 0.346 

0.5mm monocap 18.61cm 2573 6771:112 0.331 571 1310:43 0.342 

0.05mm pinhole 18.61cm       

0.1mm pinhole 18.61cm 1 4:0 0.23    

0.5mm pinhole 18.61cm 547 1924:22 0.244 117 468:9 0.178 

0.8mm pinhole 18.61cm 1591 5299:65 0.257 350 1311:27 0.191 

0.5mm monocap 28.7cm 1211 3384:50 0.314 262 606:17 0.332 

0.5mm pinhole 28.7cm 249 1498:9 0.137 50 212:3 0.165 

The X-ray beam will elongate when it hits the sample, depending on the incident-angle, omega. 

The actual length of the X-ray beam is L= d / sin(ω), where d is the diameter of the beam 
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1) Read the label on the collimator to determine what type and size is currently mounted.   

 The monocapillary collimator (monocap) has the size stamped into the metal.  

 The pinhole collimator has the size labeled with white text on black background. 

  

2) To change the collimator: 

a) Loosen the clamp and GENTLY remove the current collimator 

b) Remove the collar around the end of the collimator 

c) Put the collimator that you removed back 

into its storage container 

i) Monocaps go in the padded boxes for 

protection 

ii) Pinholes go in the plastic bag 

d) Put the collar around the end of the 

collimator that you want to use 

i) The solid collar goes on the monocap 

collimator 

(1) Line the end of the collar even 

with the end of the collimator and 

gently tighten the set screw 

ii) The spring-loaded collar goes on the 

pinhole collimator 

(1) Put the spring-loaded collar on as 

far as it will go and gently tighten 

the set screw 

e) Put the collimator in the cradle 

f) Push the collimator back until the collar 

is nestled in the monochromator 

connector 

g) Gently tighten the clamp 

 

The collimator can be moved forward, which is useful when you want to make the beam size as 

small as possible or when you want to use the beamstop (working in transmission mode at low 

detector angles). Contact SEF staff if you want to discuss this option. 

 

D. Check the Detector Distance  
The detector can be moved forward and backward on its track, which changes the distance from 

the sample to the detector (the detector distance).  

1) To determine the approximate distance of the detector from the sample,  

a) Read position of the front edge of the detector mount using the scale on the goniometer 

arm 

b) Add 100mm to that number 

c) This is the approximate detector distance.  

 

 A shorter detector distance gives more intensity and collects more diffraction data 

simultaneously, but has wider peaks and less angular resolution.  

 A longer detector distance gives better angular resolution and more accurate peak positions, 

Collimator  

Label 

Clamp 

Collar Cradle 
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but has lower intensity and less detector coverage (a smaller range is observed 

simultaneously).  

 

Moving the detector requires calibrating the detector distance and beam center.  If you would 

like the detector distance to be changed, contact SEF staff.  If you move the detector frequently, 

you can receive additional training on this procedure.   

 

 

E. Check or Change the Detector Settings in the GADDS Software 

Every time the Vantec-2000 detector is moved, the position of the detector must be recalibrated.  

This means that the detector position might be slightly different each time you use the 

instrument.  

 

A note will be posted on the monitor of the data collection computer that will report the 

current position of the detector. Confirm that these settings are configured in the software. 

 

1) Read the current settings reported by the GADDS software.   

a. This information is located in the lower right-hand corner of the GADDS software.  

 
 

2) Compare the values in the GADDS software to the values posted on the monitor.   

a. If distance and framesize are correct, proceed to step 4 (pg 8) and mount the sample 

b. If the distance is wrong or you want to change the framesize, then continue to step 3. 

 

3) Go to Edit > Configure > User Settings 

 
 

  

The values shown in this 

picture are not correct.  Look 

at the note on the monitor for 

the correct values.  
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4) The Options for Edit Configure User Settings dialogue will open.   

 
a. Focus on the values in the lower right-hand corner, in the area labeled Detector 

b. Enter the Sample to detector face distance posted on the monitor.  

c. Enter the Direct beam X (unw) and Direct beam Y (unw) values posted on the 

monitor.  

d. Select the desired Framesize from the drop-down menu 

i. The Direct beam X and Direct beam Y values might change- this is ok.   

e. Click OK 

 

5) A pop-up message will ask if you want to load the new spatial and floodfield correction 

files. Click OK.  

a. If an error message tells you that the spatial and floodfield correction files were 

collected at a different distance, do not worry.  Just click OK. 

 

6) A pop-up message may ask if you want to reset the goniometer limits 

a. Click Cancel 

b. It is very important that you do not reset the goniometer limits—doing so may prevent 

you from collecting the data that you want. 

 

Note: you can change the Framesize that you want to use.   

The framesize dictates how many pixels the detector will be divided into, and therefore affects 

the resolution of the data. A higher resolution can produce better peak shapes and angular 

resolution but will also produce larger files.  

 A 1024x1024 resolution produces 1 MB files. 

o This is the preferred resolution, and is adequate for most materials. 

 A 2048x2048 resolution produces 4 MB files.  

o This resolution is only required for highly textured or epitaxial films, or for data with 

closely spaced peaks. 

 A 512x512 resolution produces 0.5 MB files 

o This resolution is used for texture analysis of simple materials with few peaks, such 

as metals and high symmetry materials.  

 Remember, the typical pole figure will produce hundreds of files that you will need to 

analyze. You should usually use a smaller framesize if collecting a pole figure.   

The values shown in this 

picture are not correct.  Look 

at the note on the monitor for 

the correct values.  
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Not all framesizes are available for all detector positions.  The allowed combinations are: 

Detector Distance Framesize 

160 mm 1024 or 2048 

  

200 mm 1024 or 2048 

290 mm 2048 

350 mm or larger any 

 

Sometimes the correct floodield or spatial file does not load.  If this happens, manually load the 

correct floodfield and spatial files 

 Go to Process > Flood > Load 

o Click on the … button to open the folder of correction files 

o Select the appropriate *._fl file in the folder C:\frames\Calib\ 

 Go to Process > Spatial > Load 

o Click on the … button to open the folder of correction files 

o Select the appropriate *._ix file in the folder C:\frames\Calib\ 

  

 

4. MOUNT AND ALIGN THE SAMPLE 

  

A. Mount the Sample 

○ The optimal distance from the XYZ platform to the top of the sample is 4 cm. Use a 

combination of shims and sample stages to get the top of your sample as close to this 

value as possible.  

○ The motorized Z axis will allow you to drive the sample between -0.95mm to 2.5mm.  

○ Use a 1.5 mm hex wrench to tighten the SEM stub into the sample holder.  

○ Use the SEM stub extender when your sample is less than ~1 mm thick.  

 Use a 1mm hex wrench (stored in the same plastic boxes as the SEM stubs) to attach 

the SEM stub to the extender.  

 

  

From the 

bottom to the 

top of your 

sample should 

be ~4 cm. 

You can use an SEM stub by itself 

or with the extender (pictured left) 

to get your sample to the correct 

height.  
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B. Drive the Goniometer to the proper Position 

○ Go to Collect > Goniometer > Drive 

 
 

○ In the Options for Collect Goniometer Drive dialogue window, enter the values: 

 
 

○ Click OK 

 

C.  Put the instrument in manual mode 

○ Go to Collect > Goniometer > Manual 

○ In the dialog box Options for Collect Goniometer Manual, click OK 

 
 

○ When in manual mode, you can press letters on the keyboard to initiate certain actions 

 Press L  to turn on the Laser 

 Other commands available to you in manual mode are listed across the bottom of the 

GADDS window 

 !! Be Aware that pressing S will open the shutter!! 

D. Start the VIDEO Program  

 

  

When Driving the goniometer, 
you can press any key on the 
keyboard to stop the 
movement- in case you need 
to prevent a collision, for 
example 
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E. In the VIDEO program, the laser should be visible on the 

screen and near the center. If it is more than ¼ of the vertical 

length away from the center of the screen, you will need to 

readjust how the sample is mounted   

 

F. The sample is aligned when the laser light scattering off of 

your sample surface is centered in the video camera. The lines 

from the laser, video camera, and X-ray beam all focus at that 

spot.  

 
The image on the left represents the sample not yet aligned; the image on the right shows the 

sample when Z has been properly adjusted so the laser is centered on the horizontal crosshair. 

 

G. Use the Remote Control Box to adjust X, Y, and Z 

○ The remote control box allows you to manually move the goniometer 

○ If the LCD screen on the remote control box reads “Bruker D8 with GADDS” and it will 

not let you select a motor to control, press and then release the SHIFT button, and then 

press and release the F1 button on the remote control box.  

○ Pressing different numbers on the remote control box will activate different motors for 

you to move. The numbers and their corresponding motor are: 

7: Z 8: Zoom  

4: Psi 5: X 6: Y 

1: 2-Theta 2: Omega 3: Phi 

 

○ The limits for the axes are: 

Z: -0.95 to 2.5 Zoom: 1 to 6  

Psi: -12 to 92° X: -40 to 40mm Y: -40 to 40mm 

2-Theta: -6 to 102° Omega: -30 to 100° Phi: no limits 

 

○ Use the ↑↓ arrows to move the motors 

○ Adjust Z until the laser is centered on the horizontal crosshair in the Video Screen 

 Press 7 to activate the Z motor 

 If the laser is below the horizontal crosshair, use the ↑ arrow key to move Z up 

video 

sample 
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 If the laser is above the horizontal crosshair, use the ↓ arrow key to move Z down 

 The laser may be slightly off of the vertical line; this is ok 

○ Optimize the position of the laser on your sample 

 The area where the laser hits your sample is the area where the X-ray beam will be 

focused.  

 Adjust X and Y until the laser is pointed at the correct spot on your sample 

 After X and Y are adjusted, check if the laser is still centered on the horizontal 

crosshair in the Video screen 

 If necessary, readjust Z 

 

H. If desired, you can save this image from the video camera; go to File > Save 

I. When done, return to the GADDS program (click somewhere on the GADDS window) 

J. Press the ‘Esc’ key on the keyboard to exit Manual Mode in GADDS 

 

Notes for aligning tricky samples 

If your sample is translucent, then you might see multiple laser spots on the sample—an upper 

dot where the laser is scattering off the top of your sample, and a lower dot(s) where the laser is 

scattering off the sample holder under the sample (or at the interface between a coating and 

substrate). Align the uppermost dot that you can see (it will often be the weakest dot, too). 

 

If your sample reflects the laser, then you will not see the scattered laser spot at all. You can 

fix this by tilting your sample to Psi=22.5°. This will cause the sample to reflect the laser directly 

into the video camera.  

 

If your sample is completely transparent, then you will not see the scattered laser spot. There 

are three possible solutions: 

1. Put a thin tissue (kimwipe) over the top of your sample. Align the laser spot scattering off 

of the kimwipe. Your sample will be slightly misaligned (z will be too low) using this 

method, but you can use method #3 to fine tune your alignment.  

 

2. Tilt your sample to Psi=90°. Rotate Phi=60° and then drive X back by half of the width 

of your sample-- this will put the edge of your sample in focus in the video camera 

Adjust Z until the surface of the sample lies on the horizontal line in the video camera. 

This method is sometimes not as precise—you can use method #3 to fine tune your 

alignment. 

 

3. If your sample has a phase where the peak positions are known, then you can collect data 

from your sample and use the observed peak positions to adjust the alignment of Z. If the 

observed peak is lower than the reference position, then Z is too low. If the observed peak 

is higher than the reference position, then Z is too high. You can even use the Treatment 

> Corrections > Correct Displacement option in HighScore Plus to quantify how 

misaligned Z is. Be sure to set the goniometer radius (in the Object Inspector values for 

the Scan List) to the detector distance of the Bruker D8 detector (for example, set it to 

186mm if the detector is in the close position).  
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5. TURN THE GENERATOR POWER UP 

 Go to  Collect > Goniometer > Generator 

 Set the tube power to 40 kV and 40 mA 

 Click OK 

 

 

6. COLLECT DATA 

One thing to remember about using the Vantec2000 2D-detector: rather than collecting a 

continuous 1D scan like a conventional diffractometer, we usually use the 2D detector to take 

several snapshots of diffraction space- as if we were taking photos with a camera. We can then 

splice these snapshots together to form a full scan. Each snapshot is called a frame.  

 

To collect a series of frames, we use the ‘SingleRun’ option. A SingleRun can collect multiple 

frames of data changing one axis (such as the detector position, 2Theta) in between each frame. 

 

 Go to Collect > Scan >SingleRun 

 The window Options for Collect Scan SingleRun will open 

 

 Configure the Options for Collect Scan SingleRun as appropriate for collecting your data.  

 Once you are down configuring your SingleRun, then click OK to start the scan. 

 

The fields in the Options for Collect Scan SingleRun are organized as: 

 

Data Collection Options (the upper portion of the dialog window)  

○ # Frames- how many frames of diffraction data will be collected.  

 Typically, you will have a motor move (the Scan Axis, see below) in-between each frame, 

giving you data over a range of coverage 

○ Seconds/Frame- how long the detector will be exposed for each frame 

 you can enter this information as hh:mm:ss or as an integer value for seconds. 

 60 to 300 seconds/frame is a typical time for fast scans 

 Slow data collection may take as long as 1800 or 3600 seconds/frame (0.5 or 1 hr)   

○ 2-Theta, Omega, Phi, Psi, X, Y, Z- starting positions for these axes during the first frame 



 Page 14 of 27 

Revision Date: 19 Jan 2017 

 It is a good idea to make sure that X, Y, and Z properly reflect the aligned position for 

the sample that you determined in step 4 (pg 6-8). These positions do not always update 

in the SingleRun to reflect your alignment 

 You can read the current positions of all axes in the lower right-hand corner of the 

GADDS program window. 

 The limits for the axes are:  

2-Theta: -6 to 102° X: -40 to 40mm 

Omega: -30 to 100° Y: -40 to 40mm 

Psi: -12 to 92° Z: -0.95 to 2.5 

 Aux is the video camera zoom. This number should be between 1 to 6.  

 

○ Scan Axis #- this is the position/motor that will change between subsequent frames.  

 Select an option from the drop-down menu 

 Options are: 1 2T, 2 Om, 3 Phi, 4 Psi, 5 X, 6 Y, 7 Z, 8 Aux, None, and Coupled 

 2T is the 2-Theta angle 

 Om is the Omega angle 

 The value “Coupled” will change both 2Theta and Omega in a way consistent with 

Bragg-Brentano geometry. This is the most commonly used option. 

○ Frame width- how much the Scan Axis will change between each frame. 

 If the Scan Axis is 'Coupled', then this is value by which 2Theta will change (omega will 

change by 1/2 this value) 

○ Mode- how the Scan Axis will change during the run. The options are: 

 Step (the most common choice): the first frame is collected, then the scan axis changes by 

the frame width and the next frame is collected 

 Scan: as the frame is being collected, the scan axis changes by the frame width. The 

frame represents the sum of the signal observed while the scan axis was moving.  

 Oscillate: the scan axis will oscillate by the frame width during the data collection 

○ Rotate Sample if checked, the sample rotates about Phi at least once during each frame 

 sample rotation is useful if the sample is highly textured or has large grains 

○ Sample Osc—this selection can be used to oscillate the sample around a combination of X, 

Y, and Z during the each frame  

 This is useful for spreading the X-ray beam over a larger area of the sample to improve 

particle statistics for samples with a large grain size 

○ Amplitude-- how much the selected axes will oscillate during data collection 

 

Frame Header Information  
These are miscellaneous information that will be recorded in the data for record-keeping 

purposes. You can use these fields in any manner that makes sense to you 

 Title is inherited from the Title in the project (step 1), but it can be changed 

○ some people use title to indicate the overall research project, other people use it to 

indicate details specific to that data scan 

 Sample name is not inherited from the sample name that you entered when creating a 

project, but rather will be the value last entered in GADDS 

○ some people use the sample name to record details of the sample or of the instrument 

configuration, such as the beam size 
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Filename generation 
These settings are used to generate the filename(s) for each frame from the SingleRun 

 Job Name-- this makes up the prefix of the filename 

○ Limited to 26 characters 

 Run #-- this will be held constant during a SingleRun 

○ Usually this is used to differentiate slightly different measurements from the same 

sample, for example if you collected on SingleRun with the sample stationary and 

another SingleRun with the sample rotating or oscillating 

 Frame #-- this will change between different frames in the SingleRun measurement  

 

Other options 

 Max Display-- the y axis (intensity) maximum value during realtime display of data 

○ The intensity does not autoscale during data collection, so you have to guess what the 

maximum intensity should be.  

○ Typical choices are 7, 15, or 31 

 Realtime display- check this option to show the diffraction data during the measurement 

 Capture video image- check this option to save the image from the video camera before 

each frame 

 Auto Z align- never check this option 

 

The example shown on the previous page will collect 5 frames of data. The first frame will be 

collected with the detector centered at 2-Theta=30deg and Omega=15deg.  In between each 

subsequent scan, 2-Theta will change by 15deg and Omega will change by 7.5deg. Each of the 5 

frames will be collected for 60 seconds, and the sample will rotate about Phi while the frame is 

being collected.  

○ This type of measurement will produce diffraction data from 17 to 103deg 2-Theta. 
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II.  ANALYZING THE DATA  
The last frame collected will be shown in GADDS when the measurement is finished.  

 

1. To navigate through frames after data collection is finished: 

 Ctrl + Right Arrow keys will go to the next frame # for a given run # 

 Ctrl + Left Arrow keys will go to the previous frame # for a given run # 

 

2. To load other data frames 

 Go to File > Display > Open  

o You can also use File > Load to open a frame 

o You will have access to different options depending which one you use 

 
The File > Display > Open dialog  The File > Load dialog 

 

3. Using Cursors for Determining Peak Positions and Intensities 

In the GADDS program, you can activate various cursors that will allow you to extract 

approximate values for peak positions and intensities. 

 

 Go to Analyze > Cursors 

 Select a cursor 

 On-screen instructions in the bottom of the GADDS 

window show you options for manipulating that 

cursor 

○ Conic cursor (shown to the right): you control a 

point (indicated by cross-hairs). The information 

area shows you the intensity and position of the 

point.  

 You are also shown an arc. All data along that arc corresponds to the same 2-Theta 

value (it is the arc of the Debye Diffraction Ring) 

 You can use this arc to determine the position of a peak and if different spots belong 

to the same 2-Theta peak position 

○ Rbox cursor: you control a box. You are given statistics for the intensity inside the box 

(total counts, maxium counts, mean counts) 

 To change the size of the box, right-click and then drag the mouse. Right-click again 

when the box is the size that you want.   

 

!! In GADDS, the 2Theta axis goes from right to left. The center of the data shown is the 

2Theta that you specified; the rightside portion of the data are the lower 2Theta values; and 

the leftside portion of the data are the higher 2Theta values !! 
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4. To Convert Data into a 1D Scan 
In order to analyze 2D data, we usually need to convert the data into a 1D scan (intensity vs 2-Theta). We do this by 

integrating the data along Debye Rings into a single data point.  Data can be converted using Chi Integration or 

Slices. Data can also be converted using a separate program called DIFFRAC.EVA—this program is especially 

useful if you have multiple frames that you want to combine together. Once 2D data are converted into a 1D plot, 

you can load the data into HighScore Plus for analysis. 

 

A. To use Chi Integration 

With Chi integration, the integration area is constrained so that an equal 

arc length is used for each 2Theta position 

 

 Open the frame that you want to analyze  

 Go to Peaks > Integrate > Chi 

 In the window Options for Peaks Integrate Chi, you will set several 

parameters. The most important parameters are Normalize Intensity 

and Step Size 

○ If you have established values for 2theta and Chi ranges that you want to use, input them here 

 Otherwise, we will graphically edit the 2theta and Chi ranges in the next step, so don’t worry about 

changing these values 

○ The typical options for Normalize Intensity are: 

 3- Normalize by solid angle (quick approximation, peaks are broader and noisier) 

 Conic lines spaced by the specified step size are defined. The intensity for each pixel that 

intersects the conic line is summed, and then normalized by the length of the arc in the gamma 

direction.  

 5- Bin normalized (preferred, slower but more accurate) 

 Integration bins covering the specified step size are defined. The intensity for each pixel inside 

that arc, using fractional area as a weighting factor, is summed and then normalized by the 

fractional area of all of the pixels inside the bin. 

○ The best Step size depends on the framesize and detector distance.  

 For detector distance >20cm or framesize 2048, use .02 

 For detector distance <20cm and framesize 1024, use .04 

○ Click OK 

 The total area of the frame that will be analyzed is outlined in the 

GADDS windows 

 You can adjust the integration arc by pressing 1, 2, 3, or 4 on 

your keyboard and moving the mouse 

○ Remember that 2theta goes from right to left for low to high 

value 

○ 1 selects the starting 2theta (right edge) 

○ 2 selects the ending 2theta (left edge) 

○ 3 selects the starting chi (upper edge) 

○ 4 selects the ending chi (lower edge) 

○ Left-click once to stop changing the edges 

 Once the proper range is selected, left-click to integrate  

 The Integrate Options dialog opens 

○ Enter any value for Title and File name 

○ Format should be DIFFRACplus for the Bruker binary 

format 

 Plotso is the Bruker Ascii format 

○ If you check Append Y/N, then every frame that you integrate 

that has the same filename will actually be written into the same 

file. If unchecked, each frame must have a different filename 

and will be written into a different file.  

 Click OK to save the integrated 1D scan 



 Page 18 of 27 

Revision Date: 19 Jan 2017 

B. To use Slice Integration  
If integrating by slices, the procedure is almost exactly the same. The area integrated by a slice is a 

rectangular area, rather than defined by arcs. Consequently, the arc length of low 2theta positions will be 

longer than the arc length of higher 2theta. Because the slice can only use the Normalize by Solid Angle 

option, the integrated scan will be noisier and have broader peaks than if you use a Chi integration with 

Bin Normalization.  

 

 Open the frame that you want to analyze  

 Go to Peaks > Integrate > Slice 

 In the window Options for Peaks Integrate Slice, you will set several 

parameters. The most important parameters are Normalize Intensity 

and Step Size 

○ If you have established values for 2theta range, chi and height that 

you want to use, input them here 

 Otherwise, we will graphically edit the 2theta ranges, chi, and height in the next step, so don’t 

worry about changing these values 

○ The typical options for Normalize Intensity are: 

 3- Normalize by solid angle (quick approximation, peaks are broader and noisier) 

 Conic lines spaced by the specified step size are defined. The intensity for each pixel that 

intersects the conic line is summed, and then normalized by the length of the arc in the 

gamma direction.  

○ The best Step size depends on the framesize and detector distance.  

 For detector distance >20cm or framesize 2048, use .02 

 For detector distance <20cm and framesize 1024, use .04 

○ Click OK 

 The total area of the frame that will be analyzed is outlined 

in the GADDS windows 

 You can adjust the integration area by pressing 1, 2, 3, or 4 

on your keyboard and moving the mouse  

○ Remember that 2theta goes from right to left for low to 

high value 

○ 1 selects the starting 2theta (right edge) 

○ 2 selects the ending 2theta (left edge) 

○ 3 selects the angle of the integration box 

○ 4 selects the width of the integration box 

○ Left-click once to stop changing the edges 

 Once the proper range is selected, left-click to integrate  

 The Integrate Options dialog opens 

○ Enter any value for Title and File name 

○ Format should be DIFFRACplus for the Bruker binary format 

 Plotso is the Bruker Ascii format 

○ If you check Append Y/N, then every frame that you integrate that has the same filename will 

actually be written into the same file. If unchecked, each frame must have a different filename 

and will be written into a different file.  

 Click OK to save the integrated 1D scan 

 The result will be shown overtop the frame in the GADDS window.  
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C. To use 2Theta Integration  
You can also determine how the intensity of an arc varies in the chi/gamma direction. This is done by 

using a 2Theta integration. The procedure is very much the same a chi or slice integration, only now 

sections at different 2Theta values (but the same chi value) are integrated together to produce a linear plot 

of intensity vs chi.  

 

 Open the frame that you want to analyze  

 Go to Peaks > Integrate > 2Theta 

 In the window Options for Peaks Integrate 2Theta, you will 

set several parameters. The most important parameters are 

Normalize Intensity and Step Size 

○ If you have established values for 2theta range, chi and 

height that you want to use, input them here 

 Otherwise, we will graphically edit the 2theta ranges, chi, and height in the next step, so don’t 

worry about changing these values 

○ The typical options for Normalize Intensity are: 

 3- Normalize by solid angle (quick approximation, peaks are broaded and noisier) 

 Conic lines spaced by the specified step size are defined. The intensity for each pixel that 

intersects the conic line is summed, and then normalized by the length of the arc in the 

gamma direction.  

 5- Bin normalized (slower but more accurate) 

 Integration bins covering specified step size are defined. The intensity for each pixel 

inside that arc, using fractional area as a weighting factor, is summed and then 

normalized by the fractional area of all of the pixels inside the bin. 

○ The Step size tends to be coarser than used for a chi integration, along the lines of 0.05 or 0.1 

degrees.  

○ Click OK 

 The total area of the frame that will be analyzed is outlined 

in the GADDS windows 

 You can adjust the integration area by pressing 1, 2, 3, or 4 

on your keyboard and moving the mouse  

○ Remember that 2theta goes from right to left for low to 

high value 

○ 1 selects the ending 2theta (right edge) 

○ 2 selects the starting 2theta (left edge) 

○ 3 selects the starting chi (upper edge) 

○ 4 selects the ending chi (lower edge) 

○ Left-click once to stop changing the edges 

 Once the proper range is selected, left-click to integrate  

 The Integrate Options dialog opens 

○ Enter any value for Title and File name 

○ Format should be DIFFRACplus for the Bruker binary format 

 Plotso is the Bruker Ascii format 

○ If you check Append Y/N, then every frame that you integrate 

that has the same filename will actually be written into the same 

file. If unchecked, each frame must have a different filename and 

will be written into a different file.  

 Click OK to save the integrated 1D scan 

 The result will be shown overtop the frame in the GADDS window. 
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D. Using DIFFRAC.EVA to Integrate Multiple Frames  
DIFFRAC.EVA is a separate program that can be used to view and integrate a single frame or to 

merge multiple frames together for viewing and integration.  

 

DIFFRAC.EVA can be used to produce better looking images of the 2D data than is possible 

with GADDS; this is useful for insertion into reports or publications.  

 

 Start the DIFFRAC.EVA program   

 

 Select File > Import from Files... 

 

 Navigate to your frame data (.gfrm files)  

○ You can open a single frame or multiple frames (by using SHIFT+Click or CTRL+Click) 

○ If you select multiple frames, they will be merged together to form a single composite 

image in the Frame View (Merged) tab 

 

 Data will be displayed with low angle on right of composite image 

○ Right click on composite image > Mirror Horizontal  

 

 

 

 The icons along the top of the 

composite image define cursors to 

perform area integrations 

○ Select Full Frame cursor 

 The borders of the frames 

are automatically masked.  

 

 

 The Mergeable Frame List will gain a Full Frame Cursor #1 object at the bottom of the list 

 Right Click Full Fram Cursor > Tool > Integrate Cursor 

 

 

 
 

 The 2D data is transformed into a 1D profile 

○ To copy the 1D profile image directly into a presentation, Right Click on the plot 

 Copy as Bitmap or 

 Copy as Metafile  

 

Full frame Wedge Slice 
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 Save 1D profile as two column format (2 vs Intensity) 

○ In Data Command window 

 Go to Export Scan... 

 Default is .raw file  

 Change file extension to .XY format > Save 

 Text file with 2 columns that can be loaded 

into other programs. For instance, to load 

into Highscore Plus, change .XY to .ASC 

and it can be read with Highscore Plus. 

 

 

 

 

 

 

 

 

 

 

 

 

E. Merging Multiple Frames using the Merge Program 

If you collected multiple frames of data that you want to merge, you can: 

 Use DIFFRAC.EVA (as described above in step D, pg 15) 

 Use HighScore Plus to merge 1D plots produced by integrating data in GADDS using Chi or 

Slice integrations (steps B and C, pgs 12 and 13)  

 Use the Merge program to merge 1D plots produced by integrating data in GADDS using 

Chi or Slice integrations (steps B and C, pgs 12 and 13)  

 

To use the Merge program: 

 Start the Merge program 

 Specify the Project directory and the 1D plots (*.raw) that 

you want to combine. 

 Name the output file 

 Click Do It 

 Typically, the entire range of each plot is used (enter -1 in 

the range field for each dataset) 

 The alternate averaging and scaling options, available at the bottom of the Merge program 

window, are seldom used.  

 

 

 

F. Using a Rocking Curve Graph to track a change between frames 
If you collected data using an omega, phi, or psi scan axis, you can generate a plot to show how a 

specific peak or section of the data changes between frames.  
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 Load a frame from the middle of your series generated by the SingleRun 

 Go to Analyze > Graph > Rocking 

 The Options for Analyze Graph Rocking window opens. 

○ The Frame Halfwidth is how many frames before and after the current frame you want 

to include in the analysis 

○ You can specify the origin and size of the integration box in this dialogue, or you can 

change them graphically in the next step.  

○ Click OK  

 An integration box appears in the frame of the GADDS window  

○ Drag the mouse to change position of the integration box 

○ Right-click and then drag the mouse to change the size of the integration box 

 Once the integration box includes the portion of the data that you want to analyze, 

○ Left-click to process the data 

○ The intensity inside of the integration box will be summed for each frame 

○ The summed intensity will be plotted versus the scan axis position 

 To save the graph, go to Analyze > Graph > Write 

○ Fill the dialogue window that opens and click OK to save the plot 

III.  COLLECTING MULTIPLE SETS OF DATA FOR AUTOMATED MAPPING  

 

You can collect multiple sets of data using different options in the GADDS program.  

 MultiRuns allows you to create a SingleRun (see section 

6) that starts at different values of 2Theta, Omega, Psi, 

and/or Phi.  

○ For example, you could use MultiRun to collect a 

series of frames that vary 2Theta (the SingleRun) at 

different values of Psi. This would allow you to see 

how the 2Theta-Omega scan varies with the tilt of the 

sample.  

○ MultiRun is used to collect data for a polefigure. 

 MultiTargets allows you to create a SingleRun that is collected with the sample positioned 

at different X, Y, and Z values 

○ This allows you to collect a series of coupled frames with the X-ray beam focused on 

different areas of your sample so that you can map the phase distribution across your 

sample.  

 MultiTemps allows you to create a SingleRun that is collected at different temperatures 

when you are using the Anton Paar DHS900 furnace.  

 

A. MultiRun 

To create a MultiRun, you first need to produce a matrix of the different starting positions that 

you will use when collecting your data. To do this: 

 

 Go to Collect > Scan > Edit Runs 

 The Scan MultiRun List window opens 
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 In the MultiRun List, each line represents a different SingleRun.  

 For each line in the list, you should: 

○ Specify the Run# and Frame# that will be used in the filenames for that SingleRun 

○ Specify the starting values for 2-Theta, Omega, Phi, and Psi 

○ Axis is the Scan Axis that will move in-between each frame during the data collection. 

You specify the Scan Axis using a number. The numbers correspond to: 

1: 2Theta 5: X 

2: Omega 6: Y 

3: Phi 7: Z 

4: Psi  

 

○ Width is the Frame Width, i.e. how much the Scan Axis will move in-between each 

frame 

○ #Frames is the number of frames that will be collected 

○ Time is the time in seconds that will be spent collecting each frame.  

 

○ You can save this MultiRun List for use later by clicking on Write 

○ You can open a previously saved MultiRun List by clicking on Read 

 When you open a MultiRun List, it will be added to any lines already in the List. 

Remember to delete any entries in the MultiRun List before opening the saved file 

(unless you want to include those additional scans) 

 

 To execute the MultiRun after editing the List, go to Collect > Scan >MultiRun 

 The Options for Collect Scan MultiRun window will appear. 

 
 

○ Job name will be the prefix for every file created by the MultiRun 

○ Title, Sample name, and Sample number are information fields that will be saved in the 
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header of the data 

 

○ Max display counts-- the y axis (intensity) maximum value during realtime display of 

data 

 The intensity does not autoscale during data collection, so you have to guess what the 

maximum intensity should be.  

 Typical choices are 7, 15, or 31 

○ Realtime display- check this option to show the diffraction data during the measurement 

 

○ Sequence # of starting run and Sequence # of ending run refers to the lines in the 

MultiRun List that you wrote in Edit MultiRuns (previous page) 

 If you want to use the entire MultiRun List, then Sequence # of starting run should 

be 1 and Sequence # of ending run should be equal to the number of lines in the list 

 You can choose not to use every line in the MultiRun List, but rather just use a part of 

the List, by adjusting the sequence #’s 

 

○ Mode- how the Scan Axis will change during the run. The options are: 

 Step (the most common choice): the first frame is collected, then the scan axis 

changes by the frame width and the next frame is collected 

 Scan: as the frame is being collected, the scan axis changes by the frame width. The 

frame represents the sum of the signal observed while the scan axis was moving.  

 Oscillate: the scan axis will oscillate by the frame width during the data collection 

○ Rotate Sample if checked, the sample rotates about Phi at least once during each frame 

 sample rotation is useful if the sample is highly textured or has large grains 

○ Sample Osc—this selection can be used to oscillate the sample around a combination of 

X, Y, and Z during the each frame  

 This is useful for spreading the X-ray beam over a larger area of the sample to 

improve particle statistics for samples with a large grain size 

○ Amplitude-- how much the selected axes will oscillate during data collection 

○ Capture video image- check this option to save the image from the video camera before 

each frame 

 

 Click OK to start data collection once you are satisfied with your scan options. 

 

 

B. MultiTargets 

To create a MultiRun, you first need to produce a matrix of the different starting positions that 

you will use when collecting your data. To do this: 

 

 Go to Collect > Scan > Edit Targets 

 The Scan MultiTargets List window opens 



 Page 25 of 27 

Revision Date: 19 Jan 2017 

 
 

 In the MultiTarget List, each line represents a different SingleRun.  

 For each line in the list, you should: 

○ Specify the Run# and Frame# that will be used in the filenames for that SingleRun 

○ Specify the sample positions X, Y, and Z 

 You should check the alignment of Z for each locating XY that you want to examine 

on your sample, in case your sample surface is not perfectly level and/or flat 

 

○ You can save this MultiTarget List for use later by clicking on Write 

○ You can open a previously saved MultiTarget List by clicking on Read 

 When you open a MultiTarget List, it will be added to any lines already in the List. 

Remember to delete any entries in the MultiTarget List before opening the saved file 

(unless you want to include those additional scans) 

 

○ Options Collect > Scan > LineTargets and Collect > Scan >GridTargets exist to help 

you automatically generate MultiTarget Lists for collecting data along a line or grid of 

XY positions. 

 

 To execute the MultiTarget after editing the List, go to Collect > Scan >MultiTargets 

 The Options for Collect Scan MultiTargets window will appear. 

 
 

 This dialogue is almost exactly the same as the options window a SingleRun and should be 

filled out similarly. 

○ # Frames- how many frames of diffraction data will be collected.  

 Typically, you will have a motor move (the Scan Axis, see below) in-between each 

frame, giving you data over a range of coverage 
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○ 2-Theta, Omega, Phi, Psi - starting positions for these axes during the first frame 

 The limits for the axes are:  

2-Theta: -6 to 102° 

Omega: -30 to 100° 

Psi: -12 to 92° 

○ Scan Axis #- this is the position/motor that will change between subsequent frames.  

 Select an option from the drop-down menu 

 Options are: 1 2T, 2 Om, 3 Phi, 4 Psi, 5 X, 6 Y, 7 Z, 8 Aux, None, and Coupled 

 2T is the 2-Theta angle 

 Om is the Omega angle 

 The value “Coupled” will change both 2Theta and Omega in a way consistent 

with Bragg-Brentano geometry. This is the most commonly used option. 

○ Frame width- how much the Scan Axis will change between each frame. 

 If the Scan Axis is 'Coupled', then this is value by which 2Theta will change (omega 

will change by 1/2 this value) 

○ Seconds/Frame- how long the detector will be exposed for each frame 

 you can enter this information as hh:mm:ss or as an integer value for seconds. 

 60 to 300 seconds/frame is a typical time for fast scans 

 Slow data collection may take as long as 1800 or 3600 seconds/frame (0.5 or 1 hr)   

 

○ Job name will be the prefix for every file created by the MultiRun 

○ Title, Sample name, and Sample number are information fields that will be saved in the 

header of the data 

 

○ Max display counts-- the y axis (intensity) maximum value during realtime display of 

data 

 The intensity does not autoscale during data collection, so you have to guess what the 

maximum intensity should be.  

 Typical choices are 7, 15, or 31 

○ Realtime display- check this option to show the diffraction data during the measurement 

 

○ Sequence # of starting run and Sequence # of ending run refers to the lines in the 

MultiRun List that you wrote in Edit MultiRuns (previous page) 

 If you want to use the entire MultiRun List, then Sequence # of starting run should 

be 1 and Sequence # of ending run should be equal to the number of lines in the list 

 You can choose not to use every line in the MultiRun List, but rather just use a part of 

the List, by adjusting the sequence #’s 

 

○ Mode- how the Scan Axis will change during the run. The options are: 

 Step (the most common choice): the first frame is collected, then the scan axis 

changes by the frame width and the next frame is collected 

 Scan: as the frame is being collected, the scan axis changes by the frame width. The 

frame represents the sum of the signal observed while the scan axis was moving.  

 Oscillate: the scan axis will oscillate by the frame width during the data collection 

○ Rotate Sample if checked, the sample rotates about Phi at least once during each frame 

 sample rotation is useful if the sample is highly textured or has large grains 
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○ Sample Osc—this selection can be used to oscillate the sample around a combination of 

X, Y, and Z during the each frame  

 This is useful for spreading the X-ray beam over a larger area of the sample to 

improve particle statistics for samples with a large grain size 

○ Amplitude-- how much the selected axes will oscillate during data collection 

 

○ Capture video image- check this option to save the image from the video camera before 

each frame 

○ Auto Z align- never check this option 

 

 Click OK to start data collection once you are satisfied with your scan options. 


